IR27407 - Historical Analytics Scheduled Deliveries issue

Incident Report for Vonage Contact Centre (VCC)

Resolved

We have a confirmation that the issue with Historical Analytics is now resolved.
Posted Aug 04, 2026 - 14:05 BST

Investigating

We are aware of issues that may be impacting a subset of EMEA and NAM Historical Analytics scheduled PDF reports. We are working to resolve the issue as soon as possible. We’ll provide further updates within 2 hours. Thank you for your patience and understanding. If you have any questions, please contact https://www.vonage.com/support/
Posted Aug 04, 2026 - 13:36 BST
This incident affected: EMEA - London (Statistics / Reporting), EMEA - Frankfurt (Statistics / Reporting), NAM - Richmond (Statistics / Reporting), and NAM - Portland (Statistics / Reporting).