IR27243 - call connectivity issues in EMEA region

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved. We are now working to generate a full root cause analysis, which will be shared in the form of an Incident Report with affected customers.
Posted Dec 08, 2025 - 18:57 GMT

Update

The incident management team continues to work with GTT to identify the problem.
Posted Dec 08, 2025 - 14:24 GMT

Investigating

We are currently aware of an ongoing issue involving our telephony partner GTT in the EMEA region. Our Incident Management team is investigating the issue with priority.
Posted Dec 05, 2025 - 13:03 GMT
This incident affected: EMEA - London (Inbound Voice Interactions, Outbound Voice Interactions) and EMEA - Frankfurt (Inbound Voice Interactions, Outbound Voice Interactions).