IR27138 - Delay in EMEA dashboards

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved. We are now working to generate a full root cause analysis which will be shared in the form of an Incident Report with affected customers.
Posted May 13, 2025 - 06:04 BST

Identified

We have identified the problem with the database for the EMEA region. We are now progressing to recover service.
Posted May 13, 2025 - 05:11 BST

Investigating

We are currently aware of an ongoing issue affecting Dashboards in EMEA region. Our Incident Management team is investigating the issue with priority.
Posted May 13, 2025 - 05:04 BST
This incident affected: EMEA - Frankfurt (VCC Platform Supervisor & Admin).