This issue has been resolved. We are now working to generate a full root cause analysis which will be shared in the form of an Incident Report with affected customers.
Posted Sep 10, 2025 - 18:32 BST
Monitoring
Service is now recovered and we are monitoring. If you are still experiencing issues, please contact Support.
Posted Sep 10, 2025 - 18:02 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 10, 2025 - 17:31 BST
Investigating
We are currently aware of an ongoing issue affecting outbound calling via dial lists and using Log a Call for the subset of NAM Salesforce instances. Our Incident Management team is investigating the issue with priority.
Posted Sep 10, 2025 - 16:53 BST
This incident affected: NAM - Richmond (Outbound Voice Interactions, Salesforce.com Integration) and NAM - Portland (Outbound Voice Interactions, Salesforce.com Integration).