IR27006 - PCI Pal payment issues
Incident Report for Vonage Contact Centre (VCC)
Resolved
This incident has been resolved.
Posted May 31, 2024 - 10:27 BST
Monitoring
We have applied a fix and we are monitoring. If you are still experiencing issues please contact Support.
Posted May 30, 2024 - 21:26 BST
Update
We have identified the problem and we are actively working on recovering the service.
Posted May 30, 2024 - 20:57 BST
Investigating
We are currently aware of an ongoing issue affecting the PCI Pal functionality in the EMEA node. Our Incident Management team is investigating the issue with priority.
Posted May 30, 2024 - 20:31 BST
This incident affected: EMEA - London (PCI Payments) and EMEA - Frankfurt (PCI Payments).