IR27135 - WebRTC connection problems

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved in Google Chrome after the new Chrome version (136.0.7103.92/.93) was released.

Additionally, this issue has now been resolved in Microsoft Edge after the new Edge version (136.0.3240.64) was released.

If you are experiencing this issue then please use one of the following options.

- Use an alternate telephony method such as PSTN.
- Use Google Chrome Beta 137 version or Google Chrome 136.0.7103.92/.93.
- Use Microsoft Edge Beta 137 version of Microsoft Edge 136.0.3240.64
- Use an alternate browser such as Firefox
Posted May 13, 2025 - 09:55 BST

Monitoring

Google have started rolling out a new Chrome version (136.0.7103.92/.93) which contains the fix for the WebRTC issue. If you have been affected by this issue, please install the new Google Chrome version.
Posted May 06, 2025 - 21:49 BST

Update

Chromium is currently working to deploy a fixed version of Chrome 136. Currently, Chrome 137 (Beta version) is not affected by this issue.

If you are experiencing this issue then please use one of the following options.

- Rollback Chrome to 135 and pin at this version.
- Use an alternate telephony method such as PSTN.
- Use Google Chrome Beta 137 version.
- Use an alternate browser such as Firefox.
Posted May 06, 2025 - 10:04 BST

Identified

We have found an issue in Chromium browsers (Chrome and Edge) post version 135. Intermittently the browser API is very slow returning audio device information on request.

We have provided supporting information to the Chromium bug report. If you are experiencing this issue then please use one of the following options

- Rollback Chrome to 135 and pin at this version.
- Use an alternate browser such as Firefox.
- Use an alternate telephony method such as PSTN.
Posted May 02, 2025 - 14:36 BST

Update

The incident management team continues to investigate the issue as a top priority. If you are experiencing issues please perform the following troubleshooting:
- Rollback the latest Google Chrome version 136.
- Use an alternative browser like Firefox.
- Use other, alternative telephony methods, e.g. PSTN
Please contact support for any questions.
Posted May 02, 2025 - 13:13 BST

Update

The incident management team continues to investigate the issue as a top priority. If you are experiencing issues please perform the following troubleshooting:

- Rollback the latest Google Chrome version 136.
- Use an alternative browser like Microsoft Edge.

Please contact support for any questions.
Posted May 01, 2025 - 17:40 BST

Investigating

We are currently aware of an ongoing issue affecting WebRTC in the EMEA, NAM and APAC regions. Our Incident Management team is investigating the issue with priority.
Posted May 01, 2025 - 13:58 BST
This incident affected: EMEA - London (WebRTC), EMEA - Frankfurt (WebRTC), NAM - Richmond (WebRTC), NAM - Portland (WebRTC), APAC - Sydney (WebRTC), and APAC - Singapore (WebRTC).