IR27288 - Call Recordings access problems

Incident Report for Vonage Contact Centre (VCC)

Resolved

Access to call recordings has been fully restored following today's service interruption. Full resolution has been confirmed effective 2026-03-26 21:40 UTC. You will receive a formal RFO within 5 business days.

Thank you for your patience and understanding as we worked to restore services as quickly as possible.

If you have any questions, please contact https://www.vonage.com/support/
Posted Mar 23, 2026 - 22:33 GMT

Identified

We are aware of issues that may be affecting some users' access to call recordings in the Interaction Content section. Our engineers are working to resolve the issue as soon as possible. We'll provide further updates within 1 hour.

Thank you for your patience and understanding. If you have any questions, please contact https://www.vonage.com/support/
Posted Mar 23, 2026 - 21:46 GMT
This incident affected: APAC - Singapore (VCC Platform Supervisor & Admin), APAC - Sydney (VCC Platform Supervisor & Admin), EMEA - London (VCC Platform Supervisor & Admin), EMEA - Frankfurt (VCC Platform Supervisor & Admin), NAM - Richmond (VCC Platform Supervisor & Admin), and NAM - Portland (VCC Platform Supervisor & Admin).