IR27114 - Two-Factor Authentification (2FA) email delays

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved.
Posted Mar 21, 2025 - 12:33 GMT

Monitoring

Service is now recovered and we are monitoring. If you are still experiencing issues please contact Support.
Posted Mar 21, 2025 - 09:46 GMT

Investigating

We have identified an issue with the timely receipt of emailed verification codes on Two Factor Authentication logins (2FA). Our Incident Management team is working with our partner to resolve this as soon as possible. If you are impacted, please contact Support.
Posted Mar 21, 2025 - 09:23 GMT
This incident affected: APAC - Singapore (VCC Platform Supervisor & Admin), APAC - Sydney (VCC Platform Supervisor & Admin), EMEA - London (VCC Platform Supervisor & Admin), EMEA - Frankfurt (VCC Platform Supervisor & Admin), NAM - Richmond (VCC Platform Supervisor & Admin), and NAM - Portland (VCC Platform Supervisor & Admin).