IR27317 - Degraded experience on Agent Workspace in NAM region

Incident Report for Vonage Contact Centre (VCC)

Resolved

Vonage services have been fully restored following today’s service interruption, which began at 2026-04-23 11:29 UTC. Full resolution has been confirmed effective 2026-04-23 13:30 UTC. You will receive a formal RFO. Thank you for your patience and understanding as we worked to restore services as quickly as possible.

If you have any questions, please contact https://www.vonage.com/support/
Posted Apr 23, 2026 - 16:35 BST

Monitoring

Vonage services continue to show signs of recovery following today's interruption in Agent Workspace. We'll continue to provide further updates here within 6h and once full service is restored. Thank you for your patience and understanding as we work to restore services as quickly as possible. If you have any questions, please contact https://www.vonage.com/support/
Posted Apr 23, 2026 - 14:31 BST

Investigating

We are aware of issues that may be impacting the Agent Workspace service. We are working to resolve the issue as soon as possible. We’ll provide further updates within 2 hours. Thank you for your patience and understanding. If you have any questions, please contact https://www.vonage.com/support/
Posted Apr 23, 2026 - 13:37 BST
This incident affected: NAM - Richmond (Agent Workspace) and NAM - Portland (Agent Workspace).