IR27216 - Issues with calls

Incident Report for Vonage Contact Centre (VCC)

Resolved

This non Vonage incident has been resolved.
Posted Oct 14, 2025 - 15:23 BST

Monitoring

Service is now recovered, and we are monitoring. If you are still experiencing issues, please contact Support.
Posted Oct 13, 2025 - 17:46 BST

Update

We are continuing to investigate this issue.
Posted Oct 13, 2025 - 16:02 BST

Investigating

We are currently aware of an ongoing issue involving one of the third-party carriers. Our Incident Management team is investigating the issue with priority.
Posted Oct 13, 2025 - 16:01 BST
This incident affected: EMEA - London (Inbound Voice Interactions, Outbound Voice Interactions) and EMEA - Frankfurt (Inbound Voice Interactions, Outbound Voice Interactions).