IR27172 - UK mobile calls not connecting

Incident Report for Vonage Contact Centre (VCC)

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 12:12 BST

Update

We are aware that a number of UK mobile and landline networks are currently experiencing intermittent service issues, which began on Thursday 24 July 2025. These disruptions continue into Friday 25 July, as reflected in public reports and confirmed by our internal monitoring systems.
The issue has primarily affected customers of EE, BT, and, to a lesser extent, Vodafone, with users reporting difficulty making or receiving calls. These disruptions have been widely documented across national media and independent monitoring platforms such as DownDetector.
We wish to reassure you that our network remains fully operational and that these service interruptions are entirely external to our infrastructure and service environment. We do not use the affected providers in any capacity, and they are not contracted service partners. Any indirect impact to our customers is a result of the inability to connect with users on the affected networks, rather than a fault in Vonage controlled systems, and all core services on our platform continue to perform as expected.
We are actively monitoring the situation and remain in communication with industry stakeholders to ensure transparency. If your own agents are impacted we encourage you to find alternate telephony solutions, such as a PSTN desk phone or switching to WebRTC delivery for voice calls.
Thank you for your continued trust and understanding
Posted Jul 25, 2025 - 13:26 BST

Monitoring

The broadly reported issues accross multiple UK mobile network providers that we have been following shows indication of being resolved according to their publicly available Mobile Network status pages.
We will continue to monitor the situation.
Posted Jul 24, 2025 - 22:19 BST

Update

The Incident Team continues to monitor the publicly available Mobile Network status pages and work with impacted users to find alternative telephony delivery options for impacted agents (WebRTC/PSTN)
Posted Jul 24, 2025 - 16:07 BST

Update

The Incident Management Team has become aware of broadly reported issues accross multiple UK mobile network providers. We advise agents using a mobile phone make/receive calls to consider an alternate telephony method.
Posted Jul 24, 2025 - 12:49 BST

Update

The Incident Management Team has become aware of broadly reported issues accross multiple UK mobile network providers. We advise agents using a mobile phone make/receive calls to consider an alternate telephony method.
Posted Jul 24, 2025 - 12:48 BST

Update

The incident management team continues to work with the Carrier partner to recover service. We narrowed it down to +447 mobile prefix calls. If you are impacted, please raise this with our technical support,
Posted Jul 24, 2025 - 12:33 BST

Identified

We have identified the problem with one of our Carrier partners. We are actively working with the partner to recover service.
Posted Jul 24, 2025 - 12:18 BST

Investigating

We are currently aware of an ongoing issue affecting a subset inbound and outbound calls to certain EMEA number ranges. Our Incident Management team is investigating the issue with priority.
Posted Jul 24, 2025 - 11:51 BST
This incident affected: EMEA - London (Inbound Voice Interactions, Outbound Voice Interactions) and EMEA - Frankfurt (Inbound Voice Interactions, Outbound Voice Interactions).