IR27070 Inbound Calling Sweden

Incident Report for Vonage Contact Centre (VCC)

Resolved

This incident has been resolved.
Posted Oct 26, 2024 - 15:48 BST

Investigating

We have identified an issue with some incoming Swedish calls using a third party carrier. Our Incident Management team is working with our partner to resolve.
Posted Oct 26, 2024 - 13:46 BST
This incident affected: EMEA - London (Inbound Voice Interactions) and EMEA - Frankfurt (Inbound Voice Interactions).