IR27219 - Agent workspace - Unable to route digital interactions

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved, and the service is now recovered. We are now working to generate a full root cause analysis, which will be shared in the form of an Incident Report with affected customers.
Posted Oct 15, 2025 - 15:12 BST

Investigating

We have identified a problem with digital interactions in the EMEA and NAM region. We are now progressing to recover service.
Posted Oct 15, 2025 - 13:14 BST