IR27124 VCC: PCI Pal Connection Issues - NAM

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved. We are now working to generate a full root cause analysis which will be shared in the form of an Incident Report with affected customers.
Posted Apr 02, 2025 - 07:54 BST

Monitoring

A fix has been implemented by the PCI vendor and we are monitoring the results.
Posted Apr 01, 2025 - 22:48 BST

Update

We continue to coordinate with our PCI payments provider as they work to resolve their service issues.
Posted Apr 01, 2025 - 22:17 BST

Identified

We have observed a reoccurrence of the issue affecting the PCI Pal Solution. We are currently investigating the reason for the reoccurrence.
Posted Apr 01, 2025 - 21:42 BST

Monitoring

Service is now recovered and we are monitoring. If you are still experiencing issues, please contact Support.
Posted Apr 01, 2025 - 20:09 BST

Identified

We have identified the problem with the PCI Pal Solution. We are actively working with the partner to recover service.
Posted Apr 01, 2025 - 19:20 BST

Investigating

We are currently aware of an ongoing issue affecting PCI Pal payments. Our Incident Management team is investigating the issue with priority. If you are experiencing issues, please contact Support.
Posted Apr 01, 2025 - 19:08 BST
This incident affected: NAM - Richmond (PCI Payments) and NAM - Portland (PCI Payments).