Unable to raise cases via Community Hub
Incident Report for Vonage Contact Centre (VCC)
Resolved
This issue has now been resolved. We apologise for any inconvenience this has caused.
Posted Sep 10, 2024 - 12:49 BST
Investigating
We are aware of an issue with raising Support cases via Community Hub. While we are working to resolve it, please contact our Support team via phone or live chat.

UK: 08003161317
Europe: +442077608888
France: +33170377180
NAM(US): +18558006342
Australia: 1800456143 or +61272018287
Singapore: +6531583285
New Zealand: 0800001254 or +6498873826
Posted Sep 10, 2024 - 08:26 BST
This incident affected: EMEA - London (Community Hub), EMEA - Frankfurt (Community Hub), NAM - Richmond (Community Hub), NAM - Portland (Community Hub), APAC - Sydney (Community Hub), and APAC - Singapore (Community Hub).