This issue has been resolved. We are now working to generate a full root cause analysis which will be shared in the form of an Incident Report with affected customers.
Posted Aug 28, 2024 - 14:07 BST
Monitoring
Service is now recovered and we are monitoring. Stuck interactions should clear themselves, however some may still require a manual action. If you are still experiencing issues, please contact Support.
Posted Aug 27, 2024 - 23:57 BST
Identified
We have identified the problem with stuck calls. We are now progressing to recover service.
Posted Aug 27, 2024 - 22:50 BST
Investigating
We are currently aware of an ongoing issue causing stuck in the queue interactions and agents stuck in a busy status. Our Incident Management team is investigating the issue with priority.
Posted Aug 27, 2024 - 22:11 BST
This incident affected: NAM - Richmond (Inbound Voice Interactions, ContactPad).