IR27003 VCC: PCI Pal - Payment Issues
Incident Report for Vonage Contact Centre (VCC)
Resolved
Following successful resolution and a period of extensive monitoring we're now closing this incident.
Posted May 15, 2024 - 14:51 BST
Monitoring
Service is now recovered and we are monitoring. If you are still experiencing issues please contact Support.
Posted May 15, 2024 - 09:14 BST
Identified
We have identified the problem with the PCI Pal. We are actively working with the partner to recover service.
Posted May 15, 2024 - 08:59 BST
Investigating
We are currently aware of an ongoing issue involving PCI Pal Solution. Our Incident Management team is investigating the issue with priority.
Posted May 15, 2024 - 08:43 BST
This incident affected: EMEA - London (PCI Payments), EMEA - Frankfurt (PCI Payments), NAM - Richmond (PCI Payments), NAM - Portland (PCI Payments), APAC - Sydney (PCI Payments), and APAC - Singapore (PCI Payments).