IR27144 - Inbound call failures NAM

Incident Report for Vonage Contact Centre (VCC)

Resolved

This issue has been resolved. If you are still experiencing issues please contact Support.
Posted May 28, 2025 - 22:13 BST

Monitoring

We are aware of a recent issue affecting inbound calls to certain NAM number ranges. Service is now recovered and we are monitoring. If you are still experiencing issues please contact Support.
Posted May 28, 2025 - 22:08 BST
This incident affected: NAM - Richmond (Inbound Voice Interactions) and NAM - Portland (Inbound Voice Interactions).