Calls routed to busy agents
Incident Report for Vonage Contact Centre (VCC)
Resolved
This incident has been resolved.
Posted Mar 08, 2021 - 09:28 GMT
Update
We are continuing to monitor for any further occurrences of the issue.

Please note that in order for the fix to triger, affected representatives should have their browser pages refreshed at least once after that change, implemented around 2:45pm BST.
Posted Mar 04, 2021 - 18:25 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2021 - 15:30 GMT
Update
Our technical teams have completed testing the code for the remediation of this issue. We are starting the process of deploying this globally, and will post an update when this is complete.
Posted Mar 04, 2021 - 11:34 GMT
Identified
Unfortunately, we had to revert the fix as it was affecting other customers inadvertently. Our technical teams are aiming to have the permanent fix ready tomorrow afternoon. In the meantime, please instruct your agents not to double-click on the 'Ready' button as this can cause two calls to be routed to one agent.
Posted Mar 03, 2021 - 16:26 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2021 - 14:56 GMT
Identified
We have identified the issue and we are testing the fix through our pipeline to ensure it does not break any other elements of the product. We hope to roll out a fix within the next few hours. Please standby for further updates.
Posted Mar 03, 2021 - 14:13 GMT
Update
We are continuing to investigate this issue and we will share further updates shortly.
Posted Mar 03, 2021 - 13:28 GMT
Investigating
We are currently investigating a potential issue where some calls might be routed to agents who are already busy with other interactions.
If you believe that your account is also affected please contact our Customer Support team.
Posted Mar 03, 2021 - 09:59 GMT
This incident affected: EMEA - Frankfurt (Inbound Voice Interactions), APAC - Sydney (Cloud 12) (Inbound Voice Interactions), EMEA - London (Inbound Voice Interactions), EMEA - London (Cloud 8) (Inbound Voice Interactions), APAC - Singapore (Cloud 14) (Inbound Voice Interactions), NAM - California (Cloud 16) (Inbound Voice Interactions), NAM - Virginia (Cloud 17) (Inbound Voice Interactions), and EMEA - London (Cloud 11) (Inbound Voice Interactions).